Olympus Pen FT Malfunction

Several weeks ago I decided to test out the Lomography Black and White Berlin 35mm film in my Olympus Pen FT Camera.

I headed to Brighton Palace Pier since I thought that would be a nice place to try out the film.

It was an extremely cold day and the shutter decided to jam several shots into the roll.

I felt like I had no choice but to remove this roll of film from the camera to see if I could identify the problem.

I’ve since put the film into my Pentax K1000 as I didn’t use much of it so hopefully I’ll still get some photos from this roll of film.

In the meantime once I removed the film from the Olympus Pen FT, the shutter still remained jammed so I immediately knew it wasn’t the film that had caused the shutter issue.

I didn’t want to force the shutter and make things worse and I don’t know enough about the mechanics of the camera to take it apart myself.

I knew if it could be repaired, I would want it done immediately upon quotation from the camera shop. I therefore saved some money together for a few weeks, preparing myself for the costs that would potentially be involved or even worse, if it couldn’t be repaired and I’d need to buy another one.

I decided to head to my local second hand camera shop, Clocktower Camera’s in Brighton who do repairs on vintage cameras.

After a quick inspection we found out that for some reason the lens had caused the shutter jam and with the removal of the lens, then placing it back onto the camera, it worked absolutely fine again.

I felt really stupid for not trying something so obvious myself as removing the lens before taking it to a camera repair shop but at the same time there was also a great sense of relief knowing that my camera still worked and that I didn’t have to pay out any money for repairs.

I wanted to blog about this in case any other Olympus Pen FT owners end up having the same problem with their shutter so my advice is, remove the lens and put it back on. Hopefully yours will then work again too!

Instagram: natalie_smart_photography

7 thoughts on “Olympus Pen FT Malfunction

  1. Omg I feel so dumb, I didn’t even realise the FT had interchangeable lenses 😄 in all fairness, I would have made the same mistake too. It doesn’t compute to me that the lens would be linked somehow to the shutter.

    Liked by 1 person

  2. I had something similar with the Contax 139. The frame counter advances two at a time, so the last eighteen frames are shot without the counter. I got to the end of the film and it would only advance half a frame. So the shutter was not cocked, and I could not go forward. Even after the film was removed it stayed jammed, and I thought there was going to be a trip to the repairer. Next day I though to give the camera a gentle tap…lo and behold the jam freed itself and I was back in business!

    Liked by 1 person

Leave a Reply to nataliesmartfilmphotography Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s